Runtimes timeouts in azure cognite functions
Monitoring
Partial outage
Ongoing for 4d

There have been capacity problems for Azure Functions in the Azure regions that power westeurope-1 and az-eastus-1 . Since CDF Functions depend on Azure Functions, this affected the ability of CDF Functions to scale beyond 1 concurrent call for each function. The capacity issues are now alleviated somewhat, so that CDF Functions should handle at least 5 concurrent calls for each function. We are continuing to monitor the situation and working with Azure to get back to normal capacity.

Sat, Mar 29, 2025, 05:37 AM
2d ago
Affected components
Updates

Monitoring

There have been capacity problems for Azure Functions in the Azure regions that power westeurope-1 and az-eastus-1 . Since CDF Functions depend on Azure Functions, this affected the ability of CDF Functions to scale beyond 1 concurrent call for each function. The capacity issues are now alleviated somewhat, so that CDF Functions should handle at least 5 concurrent calls for each function. We are continuing to monitor the situation and working with Azure to get back to normal capacity.

Sat, Mar 29, 2025, 05:37 AM
2d earlier...

Investigating

Hi All,

The Cognite engineering team is observing increasing runtimes and timeouts across Cognite Functions. The team is actively investigating the root cause and continuing to monitor other clusters to determine if they are experiencing similar behavior. We will provide further updates as more information become available.

Wed, Mar 26, 2025, 03:40 PM
Powered by