This incident has been resolved.
Resolved
Monitoring
The engineering team has made some improvements to the service.
Investigating
The engineering team is investigating performance degradation in the Data Model service.