We have identified the cause of an issue affecting Data Modeling search and aggregate results on the az-eastus-1 cluster. This issue is limited to a specific data pattern and does not affect all customers only projects ingesting JSON data where one key is used as a prefix before a dot (.) in another key within the same JSON object are impacted.
Workaround: To avoid triggering this issue, please ensure JSON objects do not contain keys where one key shares a prefix with another key before a dot (.) or end of string. For example, a structure where one key appears as a prefix of another dot-separated key should be avoided.
Our engineering team is actively working on a permanent fix. We will provide further updates as the situation develops.
Identified
We have identified the cause of an issue affecting Data Modeling search and aggregate results on the az-eastus-1 cluster. This issue is limited to a specific data pattern and does not affect all customers only projects ingesting JSON data where one key is used as a prefix before a dot (.) in another key within the same JSON object are impacted.
Workaround: To avoid triggering this issue, please ensure JSON objects do not contain keys where one key shares a prefix with another key before a dot (.) or end of string. For example, a structure where one key appears as a prefix of another dot-separated key should be avoided.
Our engineering team is actively working on a permanent fix. We will provide further updates as the situation develops.
Investigating
We are currently investigating an issue where Data Modeling search and aggregate results are not refreshing as expected on the az-eastus-1 cluster. Users may experience incorrect or zero counts in search results, and newly ingested data may not appear in the CDF Search UI. Our engineering team has identified the root cause and a fix is currently in progress. We will provide further updates as the situation develops.