Resolved
The conditions are now stable for the API after observing the fixes applied, Therefore this incident is now resolved.
Monitoring
The limit increases are effective, and we are observing stable conditions for the API. We will monitor the progress and will proceed further depending on the observations.
Identified
Cognite has deployed a configuration change to double the DMS local concurrency limit per pod, aiming to reduce throttling and help clear the file syncing backlog in the az-eastus-1 cluster. The deployment is complete and we are monitoring relevant dashboards to assess its impact on file upload propagation and timeout rates.
Identified
The engineering team has identified the issue and is raising the relevant limits to reduce impact while closely monitoring progress.
Investigating
We are investigating an issue that may cause file upload statuses to appear delayed or incorrect. Our engineering team is actively working to identify the root cause and assess the overall impact.