Resolved
The issue has been resolved and the Custom Apps menu is visible and functional.
Monitoring
There has been an issue due to which Custom Apps menu item were not visible in the Fusion Menu.
Engineering team has deployed a fix and working on a rca.