Incident impacting events search and list APIs in statnett cluster
Resolved
Lasted for 3h

Cognite Engineering have resolved the problem causing missing events from events/search and events/list APIs

Fri, Dec 15, 2023, 11:44 AM
4 months ago
Affected components

No components marked as affected

Updates

Resolved

Cognite Engineering have resolved the problem causing missing events from events/search and events/list APIs

Fri, Dec 15, 2023, 11:44 AM
29m earlier...

Monitoring

Cognite Engineering have resolved the problem causing missing events from events/search and events/list APIs. We are currently monitoring the system to verify that the actions that are taken are sufficient for the events service to keep up with incoming changes on the statnett cluster where the incident occurred.

Fri, Dec 15, 2023, 11:15 AM
3h earlier...

Investigating

Cognite Engineering has been inviestigating an incident where the search index powering the events/list and events/search apis are unable to keep up with changes to the resource type. There is no data loss, but the events returned from the two API paths will not correctly represent the data stored in the database holding the events data.

The incident has been ongoing since 12:00 on December 14th, but the service's ability to keep up with traffic volumes have degraded over the day yesterday. End user impact should have been limited until 22:00 December 14.

Fri, Dec 15, 2023, 08:08 AM
Powered by